pfSense system upgrade failure

I was having issues with the upgrades to my pfSense box, where the UI just said "Unable to check for updates":

I logged in to the box, and tried

[2.3.4-RELEASE][admin@yggdrasil.ogre.com]/root: pkg update
Shared object "libssl.so.8" not found, required by "pkg"

 

Yeh, no good. Poking around a bit, I did the following, which seems to have resolved the issue:

[2.3.4-RELEASE][admin@yggdrasil]/root: pkg-static update -f
[2.3.4-RELEASE][admin@yggdrasil]/root: pkg-static upgrade -f

 

Why the UI isn't using the statically compiled "pkg" binary is unknown (i.e. a mystery, i.e. likely a bug :-).

AttachmentSize
Image icon Fail Update.png96.2 KB